[alsa-devel] [topic/asoc][PATCH 0/2] minor clean-ups and aic3x naming change
These two patches are generated agains Takashi's topic/asoc branch.
First one will remove unused AUDIO_NAME define from codec drivers. IMO it didn't look so readable to use this define so I end up removing it.
Second one will use uniform naming like other tlv320aic drivers for tlv320aic3x.
Signed-off-by: Jarkko Nikula jarkko.nikula@nokia.com --- sound/soc/codecs/ak4535.c | 1 - sound/soc/codecs/ssm2602.c | 1 - sound/soc/codecs/tlv320aic23.c | 1 - sound/soc/codecs/tlv320aic3x.c | 1 - sound/soc/codecs/uda1380.c | 1 - sound/soc/codecs/wm8510.c | 1 - sound/soc/codecs/wm8580.c | 1 - sound/soc/codecs/wm8731.c | 1 - sound/soc/codecs/wm8750.c | 1 - sound/soc/codecs/wm8753.c | 1 - sound/soc/codecs/wm8971.c | 1 - sound/soc/codecs/wm8990.c | 1 - 12 files changed, 0 insertions(+), 12 deletions(-)
diff --git a/sound/soc/codecs/ak4535.c b/sound/soc/codecs/ak4535.c index 088cf99..2a89b58 100644 --- a/sound/soc/codecs/ak4535.c +++ b/sound/soc/codecs/ak4535.c @@ -28,7 +28,6 @@
#include "ak4535.h"
-#define AUDIO_NAME "ak4535" #define AK4535_VERSION "0.3"
struct snd_soc_codec_device soc_codec_dev_ak4535; diff --git a/sound/soc/codecs/ssm2602.c b/sound/soc/codecs/ssm2602.c index 940ce1c..44ef0da 100644 --- a/sound/soc/codecs/ssm2602.c +++ b/sound/soc/codecs/ssm2602.c @@ -42,7 +42,6 @@
#include "ssm2602.h"
-#define AUDIO_NAME "ssm2602" #define SSM2602_VERSION "0.1"
struct snd_soc_codec_device soc_codec_dev_ssm2602; diff --git a/sound/soc/codecs/tlv320aic23.c b/sound/soc/codecs/tlv320aic23.c index c2d35e9..0fd3466 100644 --- a/sound/soc/codecs/tlv320aic23.c +++ b/sound/soc/codecs/tlv320aic23.c @@ -35,7 +35,6 @@
#include "tlv320aic23.h"
-#define AUDIO_NAME "tlv320aic23" #define AIC23_VERSION "0.1"
struct tlv320aic23_srate_reg_info { diff --git a/sound/soc/codecs/tlv320aic3x.c b/sound/soc/codecs/tlv320aic3x.c index 566a427..7cff192 100644 --- a/sound/soc/codecs/tlv320aic3x.c +++ b/sound/soc/codecs/tlv320aic3x.c @@ -48,7 +48,6 @@
#include "tlv320aic3x.h"
-#define AUDIO_NAME "aic3x" #define AIC3X_VERSION "0.2"
/* codec private data */ diff --git a/sound/soc/codecs/uda1380.c b/sound/soc/codecs/uda1380.c index d206d7f..a69ee72 100644 --- a/sound/soc/codecs/uda1380.c +++ b/sound/soc/codecs/uda1380.c @@ -36,7 +36,6 @@ #include "uda1380.h"
#define UDA1380_VERSION "0.6" -#define AUDIO_NAME "uda1380"
/* * uda1380 register cache diff --git a/sound/soc/codecs/wm8510.c b/sound/soc/codecs/wm8510.c index 75ed041..ffb41c5 100644 --- a/sound/soc/codecs/wm8510.c +++ b/sound/soc/codecs/wm8510.c @@ -27,7 +27,6 @@
#include "wm8510.h"
-#define AUDIO_NAME "wm8510" #define WM8510_VERSION "0.6"
struct snd_soc_codec_device soc_codec_dev_wm8510; diff --git a/sound/soc/codecs/wm8580.c b/sound/soc/codecs/wm8580.c index df1ffbe..056787f 100644 --- a/sound/soc/codecs/wm8580.c +++ b/sound/soc/codecs/wm8580.c @@ -36,7 +36,6 @@
#include "wm8580.h"
-#define AUDIO_NAME "wm8580" #define WM8580_VERSION "0.1"
struct pll_state { diff --git a/sound/soc/codecs/wm8731.c b/sound/soc/codecs/wm8731.c index 7b64d9a..7f8a7e3 100644 --- a/sound/soc/codecs/wm8731.c +++ b/sound/soc/codecs/wm8731.c @@ -29,7 +29,6 @@
#include "wm8731.h"
-#define AUDIO_NAME "wm8731" #define WM8731_VERSION "0.13"
struct snd_soc_codec_device soc_codec_dev_wm8731; diff --git a/sound/soc/codecs/wm8750.c b/sound/soc/codecs/wm8750.c index 4892e39..9b7296e 100644 --- a/sound/soc/codecs/wm8750.c +++ b/sound/soc/codecs/wm8750.c @@ -29,7 +29,6 @@
#include "wm8750.h"
-#define AUDIO_NAME "WM8750" #define WM8750_VERSION "0.12"
/* codec private data */ diff --git a/sound/soc/codecs/wm8753.c b/sound/soc/codecs/wm8753.c index 8c4df44..ef4f50f 100644 --- a/sound/soc/codecs/wm8753.c +++ b/sound/soc/codecs/wm8753.c @@ -51,7 +51,6 @@
#include "wm8753.h"
-#define AUDIO_NAME "wm8753" #define WM8753_VERSION "0.16"
static int caps_charge = 2000; diff --git a/sound/soc/codecs/wm8971.c b/sound/soc/codecs/wm8971.c index 974a4cd..f41a578 100644 --- a/sound/soc/codecs/wm8971.c +++ b/sound/soc/codecs/wm8971.c @@ -29,7 +29,6 @@
#include "wm8971.h"
-#define AUDIO_NAME "wm8971" #define WM8971_VERSION "0.9"
#define WM8971_REG_COUNT 43 diff --git a/sound/soc/codecs/wm8990.c b/sound/soc/codecs/wm8990.c index 63410d7..572d22b 100644 --- a/sound/soc/codecs/wm8990.c +++ b/sound/soc/codecs/wm8990.c @@ -30,7 +30,6 @@
#include "wm8990.h"
-#define AUDIO_NAME "wm8990" #define WM8990_VERSION "0.2"
/* codec private data */
Signed-off-by: Jarkko Nikula jarkko.nikula@nokia.com --- sound/soc/codecs/tlv320aic3x.c | 4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/sound/soc/codecs/tlv320aic3x.c b/sound/soc/codecs/tlv320aic3x.c index 7cff192..05336ed 100644 --- a/sound/soc/codecs/tlv320aic3x.c +++ b/sound/soc/codecs/tlv320aic3x.c @@ -990,7 +990,7 @@ EXPORT_SYMBOL_GPL(aic3x_headset_detected); SNDRV_PCM_FMTBIT_S24_3LE | SNDRV_PCM_FMTBIT_S32_LE)
struct snd_soc_dai aic3x_dai = { - .name = "aic3x", + .name = "tlv320aic3x", .playback = { .stream_name = "Playback", .channels_min = 1, @@ -1054,7 +1054,7 @@ static int aic3x_init(struct snd_soc_device *socdev) struct aic3x_setup_data *setup = socdev->codec_data; int reg, ret = 0;
- codec->name = "aic3x"; + codec->name = "tlv320aic3x"; codec->owner = THIS_MODULE; codec->read = aic3x_read_reg_cache; codec->write = aic3x_write;
On Tue, Oct 07, 2008 at 02:49:21PM +0300, Jarkko Nikula wrote:
These two patches are generated agains Takashi's topic/asoc branch.
First one will remove unused AUDIO_NAME define from codec drivers. IMO it didn't look so readable to use this define so I end up removing it.
Second one will use uniform naming like other tlv320aic drivers for tlv320aic3x.
Thanks - both are
Acked-by: Mark Brown broonie@opensource.wolfsonmicro.com
Takashi, I have a small patch queue building up for you - I'll add these to that.
At Tue, 7 Oct 2008 13:00:42 +0100, Mark Brown wrote:
On Tue, Oct 07, 2008 at 02:49:21PM +0300, Jarkko Nikula wrote:
These two patches are generated agains Takashi's topic/asoc branch.
First one will remove unused AUDIO_NAME define from codec drivers. IMO it didn't look so readable to use this define so I end up removing it.
Second one will use uniform naming like other tlv320aic drivers for tlv320aic3x.
Thanks - both are
Acked-by: Mark Brown broonie@opensource.wolfsonmicro.com
Takashi, I have a small patch queue building up for you - I'll add these to that.
OK, I'll wait for your patches.
thanks,
Takashi
participants (3)
-
Jarkko Nikula
-
Mark Brown
-
Takashi Iwai