[PATCH] ALSA: ymfpci: Use register macro in place of integer literal
The macro for said register already exists, so just use it, to make the code more readable.
Signed-off-by: Tasos Sahanidis tasos@tasossah.com --- sound/pci/ymfpci/ymfpci_main.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/sound/pci/ymfpci/ymfpci_main.c b/sound/pci/ymfpci/ymfpci_main.c index 2858736ed..24378f6fd 100644 --- a/sound/pci/ymfpci/ymfpci_main.c +++ b/sound/pci/ymfpci/ymfpci_main.c @@ -2214,7 +2214,7 @@ static void snd_ymfpci_free(struct snd_card *card)
snd_ymfpci_free_gameport(chip); - pci_write_config_word(chip->pci, 0x40, chip->old_legacy_ctrl); + pci_write_config_word(chip->pci, PCIR_DSXG_LEGACY, chip->old_legacy_ctrl); release_firmware(chip->dsp_microcode); release_firmware(chip->controller_microcode);
On Wed, 29 Mar 2023 06:39:18 +0200, Tasos Sahanidis wrote:
The macro for said register already exists, so just use it, to make the code more readable.
Signed-off-by: Tasos Sahanidis tasos@tasossah.com
Applied to for-next branch.
thanks,
Takashi
participants (2)
-
Takashi Iwai
-
Tasos Sahanidis