[alsa-devel] [PATCH v2] ALSA: xen-front: Refine indentations and constify snd_pcm_ops
snd_pcm_ops are not supposed to change. So mark the non-const structs as const. Also, refine indentation to increase readability.
Signed-off-by: Nick Simonov nicksimonovv@gmail.com --- Changes v2: - Fix typo in commit description, ncrease to increase.
sound/xen/xen_snd_front_alsa.c | 46 +++++++++++++++++++++--------------------- 1 file changed, 23 insertions(+), 23 deletions(-)
diff --git a/sound/xen/xen_snd_front_alsa.c b/sound/xen/xen_snd_front_alsa.c index 129180e..2cbd967 100644 --- a/sound/xen/xen_snd_front_alsa.c +++ b/sound/xen/xen_snd_front_alsa.c @@ -637,31 +637,31 @@ static int alsa_pb_fill_silence(struct snd_pcm_substream *substream, * to know when the buffer can be transferred to the backend. */
-static struct snd_pcm_ops snd_drv_alsa_playback_ops = { - .open = alsa_open, - .close = alsa_close, - .ioctl = snd_pcm_lib_ioctl, - .hw_params = alsa_hw_params, - .hw_free = alsa_hw_free, - .prepare = alsa_prepare, - .trigger = alsa_trigger, - .pointer = alsa_pointer, - .copy_user = alsa_pb_copy_user, - .copy_kernel = alsa_pb_copy_kernel, - .fill_silence = alsa_pb_fill_silence, +static const struct snd_pcm_ops snd_drv_alsa_playback_ops = { + .open = alsa_open, + .close = alsa_close, + .ioctl = snd_pcm_lib_ioctl, + .hw_params = alsa_hw_params, + .hw_free = alsa_hw_free, + .prepare = alsa_prepare, + .trigger = alsa_trigger, + .pointer = alsa_pointer, + .copy_user = alsa_pb_copy_user, + .copy_kernel = alsa_pb_copy_kernel, + .fill_silence = alsa_pb_fill_silence, };
-static struct snd_pcm_ops snd_drv_alsa_capture_ops = { - .open = alsa_open, - .close = alsa_close, - .ioctl = snd_pcm_lib_ioctl, - .hw_params = alsa_hw_params, - .hw_free = alsa_hw_free, - .prepare = alsa_prepare, - .trigger = alsa_trigger, - .pointer = alsa_pointer, - .copy_user = alsa_cap_copy_user, - .copy_kernel = alsa_cap_copy_kernel, +static const struct snd_pcm_ops snd_drv_alsa_capture_ops = { + .open = alsa_open, + .close = alsa_close, + .ioctl = snd_pcm_lib_ioctl, + .hw_params = alsa_hw_params, + .hw_free = alsa_hw_free, + .prepare = alsa_prepare, + .trigger = alsa_trigger, + .pointer = alsa_pointer, + .copy_user = alsa_cap_copy_user, + .copy_kernel = alsa_cap_copy_kernel, };
static int new_pcm_instance(struct xen_snd_front_card_info *card_info,
On Fri, 21 Sep 2018 07:47:38 +0200, Nick Simonov wrote:
snd_pcm_ops are not supposed to change. So mark the non-const structs as const. Also, refine indentation to increase readability.
Signed-off-by: Nick Simonov nicksimonovv@gmail.com
Changes v2:
- Fix typo in commit description, ncrease to increase.
Since I already merged your first version, please resubmit as an incremental patch. At best, check the latest linux-next or my sound.git tree for-next branch, and create a patch on its top.
thanks,
Takashi
On Fri, Sep 21, 2018 at 08:51:51AM +0200, Takashi Iwai wrote:
On Fri, 21 Sep 2018 07:47:38 +0200, Nick Simonov wrote:
snd_pcm_ops are not supposed to change. So mark the non-const structs as const. Also, refine indentation to increase readability.
Signed-off-by: Nick Simonov nicksimonovv@gmail.com
Changes v2:
- Fix typo in commit description, ncrease to increase.
Since I already merged your first version, please resubmit as an incremental patch. At best, check the latest linux-next or my sound.git tree for-next branch, and create a patch on its top.
thanks,
Takashi
Sorry I want to clarify, there is no mistakes in the code itself there is a typo in commit message. As I now there is no way to change commit message without rebase after merge, so which is the proper way in this case? leave it as is?
Thanks,
Nick
On Fri, 21 Sep 2018 11:21:35 +0200, Nick Simonov wrote:
On Fri, Sep 21, 2018 at 08:51:51AM +0200, Takashi Iwai wrote:
On Fri, 21 Sep 2018 07:47:38 +0200, Nick Simonov wrote:
snd_pcm_ops are not supposed to change. So mark the non-const structs as const. Also, refine indentation to increase readability.
Signed-off-by: Nick Simonov nicksimonovv@gmail.com
Changes v2:
- Fix typo in commit description, ncrease to increase.
Since I already merged your first version, please resubmit as an incremental patch. At best, check the latest linux-next or my sound.git tree for-next branch, and create a patch on its top.
thanks,
Takashi
Sorry I want to clarify, there is no mistakes in the code itself there is a typo in commit message. As I now there is no way to change commit message without rebase after merge, so which is the proper way in this case? leave it as is?
Then let's leave as is.
thanks,
Takashi
participants (2)
-
Nick Simonov
-
Takashi Iwai