[alsa-devel] [PATCH] ASoC: rt5677-spi: Rename driver to differentiate from main codec
Currently the SPI driver and the main codec share the same name. This will become confusing when looking up components when using both drivers.
Signed-off-by: Curtis Malainey cujomalainey@chromium.org --- sound/soc/codecs/rt5677-spi.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/sound/soc/codecs/rt5677-spi.c b/sound/soc/codecs/rt5677-spi.c index 84b6bd8b50e1..871ccb37318d 100644 --- a/sound/soc/codecs/rt5677-spi.c +++ b/sound/soc/codecs/rt5677-spi.c @@ -29,6 +29,8 @@
#include "rt5677-spi.h"
+#define DRV_NAME "rt5677spi" + #define RT5677_SPI_BURST_LEN 240 #define RT5677_SPI_HEADER 5 #define RT5677_SPI_FREQ 6000000 @@ -232,7 +234,7 @@ MODULE_DEVICE_TABLE(acpi, rt5677_spi_acpi_id);
static struct spi_driver rt5677_spi_driver = { .driver = { - .name = "rt5677", + .name = DRV_NAME, .acpi_match_table = ACPI_PTR(rt5677_spi_acpi_id), }, .probe = rt5677_spi_probe,
The patch
ASoC: rt5677-spi: Rename driver to differentiate from main codec
has been applied to the asoc tree at
https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-5.3
All being well this means that it will be integrated into the linux-next tree (usually sometime in the next 24 hours) and sent to Linus during the next merge window (or sooner if it is a bug fix), however if problems are discovered then the patch may be dropped or reverted.
You may get further e-mails resulting from automated or manual testing and review of the tree, please engage with people reporting problems and send followup patches addressing any issues that are reported if needed.
If any updates are required or you are submitting further changes they should be sent as incremental updates against current git, existing patches will not be replaced.
Please add any relevant lists and maintainers to the CCs when replying to this mail.
Thanks, Mark
From b9960f6ea22da072c2fb27305a1a51517c3643fe Mon Sep 17 00:00:00 2001
From: Curtis Malainey cujomalainey@chromium.org Date: Fri, 3 May 2019 12:33:42 -0700 Subject: [PATCH] ASoC: rt5677-spi: Rename driver to differentiate from main codec
Currently the SPI driver and the main codec share the same name. This will become confusing when looking up components when using both drivers.
Signed-off-by: Curtis Malainey cujomalainey@chromium.org Signed-off-by: Mark Brown broonie@kernel.org --- sound/soc/codecs/rt5677-spi.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/sound/soc/codecs/rt5677-spi.c b/sound/soc/codecs/rt5677-spi.c index 167a02773a0b..1efc37ee625f 100644 --- a/sound/soc/codecs/rt5677-spi.c +++ b/sound/soc/codecs/rt5677-spi.c @@ -29,6 +29,8 @@
#include "rt5677-spi.h"
+#define DRV_NAME "rt5677spi" + #define RT5677_SPI_BURST_LEN 240 #define RT5677_SPI_HEADER 5 #define RT5677_SPI_FREQ 6000000 @@ -235,7 +237,7 @@ MODULE_DEVICE_TABLE(acpi, rt5677_spi_acpi_id);
static struct spi_driver rt5677_spi_driver = { .driver = { - .name = "rt5677", + .name = DRV_NAME, .acpi_match_table = ACPI_PTR(rt5677_spi_acpi_id), }, .probe = rt5677_spi_probe,
The patch
ASoC: rt5677-spi: Rename driver to differentiate from main codec
has been applied to the asoc tree at
https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-5.3
All being well this means that it will be integrated into the linux-next tree (usually sometime in the next 24 hours) and sent to Linus during the next merge window (or sooner if it is a bug fix), however if problems are discovered then the patch may be dropped or reverted.
You may get further e-mails resulting from automated or manual testing and review of the tree, please engage with people reporting problems and send followup patches addressing any issues that are reported if needed.
If any updates are required or you are submitting further changes they should be sent as incremental updates against current git, existing patches will not be replaced.
Please add any relevant lists and maintainers to the CCs when replying to this mail.
Thanks, Mark
From b9960f6ea22da072c2fb27305a1a51517c3643fe Mon Sep 17 00:00:00 2001
From: Curtis Malainey cujomalainey@chromium.org Date: Fri, 3 May 2019 12:33:42 -0700 Subject: [PATCH] ASoC: rt5677-spi: Rename driver to differentiate from main codec
Currently the SPI driver and the main codec share the same name. This will become confusing when looking up components when using both drivers.
Signed-off-by: Curtis Malainey cujomalainey@chromium.org Signed-off-by: Mark Brown broonie@kernel.org --- sound/soc/codecs/rt5677-spi.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/sound/soc/codecs/rt5677-spi.c b/sound/soc/codecs/rt5677-spi.c index 167a02773a0b..1efc37ee625f 100644 --- a/sound/soc/codecs/rt5677-spi.c +++ b/sound/soc/codecs/rt5677-spi.c @@ -29,6 +29,8 @@
#include "rt5677-spi.h"
+#define DRV_NAME "rt5677spi" + #define RT5677_SPI_BURST_LEN 240 #define RT5677_SPI_HEADER 5 #define RT5677_SPI_FREQ 6000000 @@ -235,7 +237,7 @@ MODULE_DEVICE_TABLE(acpi, rt5677_spi_acpi_id);
static struct spi_driver rt5677_spi_driver = { .driver = { - .name = "rt5677", + .name = DRV_NAME, .acpi_match_table = ACPI_PTR(rt5677_spi_acpi_id), }, .probe = rt5677_spi_probe,
The patch
ASoC: rt5677-spi: Rename driver to differentiate from main codec
has been applied to the asoc tree at
https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-5.3
All being well this means that it will be integrated into the linux-next tree (usually sometime in the next 24 hours) and sent to Linus during the next merge window (or sooner if it is a bug fix), however if problems are discovered then the patch may be dropped or reverted.
You may get further e-mails resulting from automated or manual testing and review of the tree, please engage with people reporting problems and send followup patches addressing any issues that are reported if needed.
If any updates are required or you are submitting further changes they should be sent as incremental updates against current git, existing patches will not be replaced.
Please add any relevant lists and maintainers to the CCs when replying to this mail.
Thanks, Mark
From b9960f6ea22da072c2fb27305a1a51517c3643fe Mon Sep 17 00:00:00 2001
From: Curtis Malainey cujomalainey@chromium.org Date: Fri, 3 May 2019 12:33:42 -0700 Subject: [PATCH] ASoC: rt5677-spi: Rename driver to differentiate from main codec
Currently the SPI driver and the main codec share the same name. This will become confusing when looking up components when using both drivers.
Signed-off-by: Curtis Malainey cujomalainey@chromium.org Signed-off-by: Mark Brown broonie@kernel.org --- sound/soc/codecs/rt5677-spi.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/sound/soc/codecs/rt5677-spi.c b/sound/soc/codecs/rt5677-spi.c index 167a02773a0b..1efc37ee625f 100644 --- a/sound/soc/codecs/rt5677-spi.c +++ b/sound/soc/codecs/rt5677-spi.c @@ -29,6 +29,8 @@
#include "rt5677-spi.h"
+#define DRV_NAME "rt5677spi" + #define RT5677_SPI_BURST_LEN 240 #define RT5677_SPI_HEADER 5 #define RT5677_SPI_FREQ 6000000 @@ -235,7 +237,7 @@ MODULE_DEVICE_TABLE(acpi, rt5677_spi_acpi_id);
static struct spi_driver rt5677_spi_driver = { .driver = { - .name = "rt5677", + .name = DRV_NAME, .acpi_match_table = ACPI_PTR(rt5677_spi_acpi_id), }, .probe = rt5677_spi_probe,
The patch
ASoC: rt5677-spi: Rename driver to differentiate from main codec
has been applied to the asoc tree at
https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-5.3
All being well this means that it will be integrated into the linux-next tree (usually sometime in the next 24 hours) and sent to Linus during the next merge window (or sooner if it is a bug fix), however if problems are discovered then the patch may be dropped or reverted.
You may get further e-mails resulting from automated or manual testing and review of the tree, please engage with people reporting problems and send followup patches addressing any issues that are reported if needed.
If any updates are required or you are submitting further changes they should be sent as incremental updates against current git, existing patches will not be replaced.
Please add any relevant lists and maintainers to the CCs when replying to this mail.
Thanks, Mark
From b9960f6ea22da072c2fb27305a1a51517c3643fe Mon Sep 17 00:00:00 2001
From: Curtis Malainey cujomalainey@chromium.org Date: Fri, 3 May 2019 12:33:42 -0700 Subject: [PATCH] ASoC: rt5677-spi: Rename driver to differentiate from main codec
Currently the SPI driver and the main codec share the same name. This will become confusing when looking up components when using both drivers.
Signed-off-by: Curtis Malainey cujomalainey@chromium.org Signed-off-by: Mark Brown broonie@kernel.org --- sound/soc/codecs/rt5677-spi.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/sound/soc/codecs/rt5677-spi.c b/sound/soc/codecs/rt5677-spi.c index 167a02773a0b..1efc37ee625f 100644 --- a/sound/soc/codecs/rt5677-spi.c +++ b/sound/soc/codecs/rt5677-spi.c @@ -29,6 +29,8 @@
#include "rt5677-spi.h"
+#define DRV_NAME "rt5677spi" + #define RT5677_SPI_BURST_LEN 240 #define RT5677_SPI_HEADER 5 #define RT5677_SPI_FREQ 6000000 @@ -235,7 +237,7 @@ MODULE_DEVICE_TABLE(acpi, rt5677_spi_acpi_id);
static struct spi_driver rt5677_spi_driver = { .driver = { - .name = "rt5677", + .name = DRV_NAME, .acpi_match_table = ACPI_PTR(rt5677_spi_acpi_id), }, .probe = rt5677_spi_probe,
participants (2)
-
Curtis Malainey
-
Mark Brown