[alsa-devel] [PATCH 1264/1285] Replace numeric parameter like 0444 with macro
I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu chuansheng.liu@intel.com Signed-off-by: Baole Ni baolex.ni@intel.com --- sound/ppc/snd_ps3.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/sound/ppc/snd_ps3.c b/sound/ppc/snd_ps3.c index 3682425..594d694 100644 --- a/sound/ppc/snd_ps3.c +++ b/sound/ppc/snd_ps3.c @@ -51,15 +51,15 @@ static struct snd_ps3_card_info the_card;
static int snd_ps3_start_delay = CONFIG_SND_PS3_DEFAULT_START_DELAY;
-module_param_named(start_delay, snd_ps3_start_delay, uint, 0644); +module_param_named(start_delay, snd_ps3_start_delay, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(start_delay, "time to insert silent data in ms");
static int index = SNDRV_DEFAULT_IDX1; static char *id = SNDRV_DEFAULT_STR1;
-module_param(index, int, 0444); +module_param(index, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(index, "Index value for PS3 soundchip."); -module_param(id, charp, 0444); +module_param(id, charp, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(id, "ID string for PS3 soundchip.");
participants (1)
-
Baole Ni