[alsa-devel] [PATCH 1210/1285] Replace numeric parameter like 0444 with macro
I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu chuansheng.liu@intel.com Signed-off-by: Baole Ni baolex.ni@intel.com --- sound/pci/atiixp_modem.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/sound/pci/atiixp_modem.c b/sound/pci/atiixp_modem.c index c534552..848a9b2 100644 --- a/sound/pci/atiixp_modem.c +++ b/sound/pci/atiixp_modem.c @@ -43,16 +43,16 @@ static int index = -2; /* Exclude the first card */ static char *id = SNDRV_DEFAULT_STR1; /* ID for this card */ static int ac97_clock = 48000;
-module_param(index, int, 0444); +module_param(index, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(index, "Index value for ATI IXP controller."); -module_param(id, charp, 0444); +module_param(id, charp, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(id, "ID string for ATI IXP controller."); -module_param(ac97_clock, int, 0444); +module_param(ac97_clock, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(ac97_clock, "AC'97 codec clock (default 48000Hz).");
/* just for backward compatibility */ static bool enable; -module_param(enable, bool, 0444); +module_param(enable, bool, S_IRUSR | S_IRGRP | S_IROTH);
/*
participants (1)
-
Baole Ni