[alsa-devel] [PATCH repost] ASoC: fsl/pcm030 add unique dai_link names
Assign each dai_link a unique name to avoid this run-time error.
[ 18.978043] pcm030-audio-fabric sound.2: wm9712-hifi <-> mpc5200-psc-ac97.0 mapping ok [ 19.003179] sysfs: cannot create duplicate filename '/devices/sound.2/AC97'
Signed-off-by: Eric Millbrandt emillbrandt@dekaresearch.com --- sound/soc/fsl/pcm030-audio-fabric.c | 4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/sound/soc/fsl/pcm030-audio-fabric.c b/sound/soc/fsl/pcm030-audio-fabric.c index 4b63ec8..4d26192 100644 --- a/sound/soc/fsl/pcm030-audio-fabric.c +++ b/sound/soc/fsl/pcm030-audio-fabric.c @@ -29,14 +29,14 @@ struct pcm030_audio_data {
static struct snd_soc_dai_link pcm030_fabric_dai[] = { { - .name = "AC97", + .name = "AC97.0", .stream_name = "AC97 Analog", .codec_dai_name = "wm9712-hifi", .cpu_dai_name = "mpc5200-psc-ac97.0", .codec_name = "wm9712-codec", }, { - .name = "AC97", + .name = "AC97.1", .stream_name = "AC97 IEC958", .codec_dai_name = "wm9712-aux", .cpu_dai_name = "mpc5200-psc-ac97.1",
On Wed, Oct 10, 2012 at 10:10:08AM -0400, Eric Millbrandt wrote:
Assign each dai_link a unique name to avoid this run-time error.
Applied, thanks. Though can't we think of more descriptive names?
participants (2)
-
Eric Millbrandt
-
Mark Brown