Re: [alsa-devel] [PATCH] hdspm.c: make driver name generic to avoid user confusion
On Tue, Jun 07, 2011 at 10:44:18AM +0200, Jörn Nettingsmeier wrote:
hi adi, *!
Hi!
here's a trivial patch to change the driver name of hdspm.c to avoid irritating users who don't have the MADI version (just happened on the LAU list).
static struct pci_driver driver = {
- .name = "RME Hammerfall DSP MADI",
- .name = "RME Hammerfall HDSPe Series",
Are braces allowed in driver names? I guess so.
"HDSPe" is also confusing, only referring to the PCIe versions. Since we also support the old PCI versions, I suggest to name it
"RME Hammerfall HDSP(e) Series"
On the other hand, the 'H' in "HDSP" stands for "Hammerfall", so
"RME HDSP(e) Series"
would be more appropriate. Luckily, we don't collide with the hdsp.c driver name, but still, it's misleading, because there are cards that match "RME HDSP(e) Series" (like the Multiface/Digiface) but are handled by hdsp.c instead.
What at mess. ;) Merging hdsp.c into hdspm.c would be the clean approach to this problem, still I don't have time for this in the near future. Maybe in July.
Given that all current variants are misleading in one way or another, we could also leave everything as is. What do you think?
Cheers
At Tue, 7 Jun 2011 11:11:32 +0200, Adrian Knoth wrote:
On Tue, Jun 07, 2011 at 10:44:18AM +0200, Jörn Nettingsmeier wrote:
hi adi, *!
Hi!
here's a trivial patch to change the driver name of hdspm.c to avoid irritating users who don't have the MADI version (just happened on the LAU list).
static struct pci_driver driver = {
- .name = "RME Hammerfall DSP MADI",
- .name = "RME Hammerfall HDSPe Series",
Are braces allowed in driver names? I guess so.
"HDSPe" is also confusing, only referring to the PCIe versions. Since we also support the old PCI versions, I suggest to name it
"RME Hammerfall HDSP(e) Series"
On the other hand, the 'H' in "HDSP" stands for "Hammerfall", so
"RME HDSP(e) Series"
would be more appropriate. Luckily, we don't collide with the hdsp.c driver name, but still, it's misleading, because there are cards that match "RME HDSP(e) Series" (like the Multiface/Digiface) but are handled by hdsp.c instead.
It's allowed but better to avoid, since this entry appears as a file name in /sys. We've chosen generic names for the pci name entries of sound drivers, but these look messy. Maybe we should choose just the module name as pci name.
thanks,
Takashi
At Tue, 07 Jun 2011 12:39:33 +0200, Takashi Iwai wrote:
At Tue, 7 Jun 2011 11:11:32 +0200, Adrian Knoth wrote:
On Tue, Jun 07, 2011 at 10:44:18AM +0200, Jörn Nettingsmeier wrote:
hi adi, *!
Hi!
here's a trivial patch to change the driver name of hdspm.c to avoid irritating users who don't have the MADI version (just happened on the LAU list).
static struct pci_driver driver = {
- .name = "RME Hammerfall DSP MADI",
- .name = "RME Hammerfall HDSPe Series",
Are braces allowed in driver names? I guess so.
"HDSPe" is also confusing, only referring to the PCIe versions. Since we also support the old PCI versions, I suggest to name it
"RME Hammerfall HDSP(e) Series"
On the other hand, the 'H' in "HDSP" stands for "Hammerfall", so
"RME HDSP(e) Series"
would be more appropriate. Luckily, we don't collide with the hdsp.c driver name, but still, it's misleading, because there are cards that match "RME HDSP(e) Series" (like the Multiface/Digiface) but are handled by hdsp.c instead.
It's allowed but better to avoid, since this entry appears as a file name in /sys. We've chosen generic names for the pci name entries of sound drivers, but these look messy. Maybe we should choose just the module name as pci name.
Looking through the whole tree, the majority is to use the module name as pci_driver.name indeed. We should follow the convention, too.
So, Adrian, please don't take this to your patchset. I'm going to fix all sound/pci/* up once for 3.1 kernel.
Takashi
At Tue, 07 Jun 2011 12:39:33 +0200, Takashi Iwai wrote:
At Tue, 7 Jun 2011 11:11:32 +0200, Adrian Knoth wrote:
On Tue, Jun 07, 2011 at 10:44:18AM +0200, Jörn Nettingsmeier wrote:
hi adi, *!
Hi!
here's a trivial patch to change the driver name of hdspm.c to avoid irritating users who don't have the MADI version (just happened on the LAU list).
static struct pci_driver driver = {
- .name = "RME Hammerfall DSP MADI",
- .name = "RME Hammerfall HDSPe Series",
Are braces allowed in driver names? I guess so.
"HDSPe" is also confusing, only referring to the PCIe versions. Since we also support the old PCI versions, I suggest to name it
"RME Hammerfall HDSP(e) Series"
On the other hand, the 'H' in "HDSP" stands for "Hammerfall", so
"RME HDSP(e) Series"
would be more appropriate. Luckily, we don't collide with the hdsp.c driver name, but still, it's misleading, because there are cards that match "RME HDSP(e) Series" (like the Multiface/Digiface) but are handled by hdsp.c instead.
It's allowed but better to avoid, since this entry appears as a file name in /sys. We've chosen generic names for the pci name entries of sound drivers, but these look messy. Maybe we should choose just the module name as pci name.
OK, now I fixed the issues in all sound/pci/* drivers in sound git tree. Now they simply use KBUILD_MODNAME in the name field.
thanks,
Takashi
On 06/07/2011 11:11 AM, Adrian Knoth wrote:
"HDSPe" is also confusing, only referring to the PCIe versions. Since we also support the old PCI versions, I suggest to name it
"RME Hammerfall HDSP(e) Series"
On the other hand, the 'H' in "HDSP" stands for "Hammerfall", so
"RME HDSP(e) Series"
would be more appropriate. Luckily, we don't collide with the hdsp.c driver name, but still, it's misleading, because there are cards that match "RME HDSP(e) Series" (like the Multiface/Digiface) but are handled by hdsp.c instead.
What at mess. ;) Merging hdsp.c into hdspm.c would be the clean approach to this problem, still I don't have time for this in the near future. Maybe in July.
Given that all current variants are misleading in one way or another, we could also leave everything as is. What do you think?
no. MADI is way too specific, and the only reason it's there is that winni started with just the MADI card...
enumerate supported cards? "RME HDSP AES32, AIO, RayDAT, MADI, MADIface" kludgy, but less potential for user confusion.
participants (3)
-
Adrian Knoth
-
Jörn Nettingsmeier
-
Takashi Iwai