[PATCH v2 1/5] ASoC: amd: Renaming snd-soc-card structure and fields
As in future our machine driver supports multiple codecs So changing naming convention of snd_soc_card struct and its fields.
Signed-off-by: Ravulapati Vishnu vardhan rao Vishnuvardhanrao.Ravulapati@amd.com --- sound/soc/amd/acp3x-rt5682-max9836.c | 28 ++++++++++++++-------------- 1 file changed, 14 insertions(+), 14 deletions(-)
diff --git a/sound/soc/amd/acp3x-rt5682-max9836.c b/sound/soc/amd/acp3x-rt5682-max9836.c index 6009e444b858..8b5af064864f 100644 --- a/sound/soc/amd/acp3x-rt5682-max9836.c +++ b/sound/soc/amd/acp3x-rt5682-max9836.c @@ -290,7 +290,7 @@ static const struct snd_kcontrol_new acp3x_dmic_mux_control = SOC_DAPM_ENUM_EXT("DMIC Select Mux", acp3x_dmic_enum, dmic_get, dmic_set);
-static const struct snd_soc_dapm_widget acp3x_widgets[] = { +static const struct snd_soc_dapm_widget acp3x_5682_widgets[] = { SND_SOC_DAPM_HP("Headphone Jack", NULL), SND_SOC_DAPM_SPK("Spk", NULL), SND_SOC_DAPM_MIC("Headset Mic", NULL), @@ -298,7 +298,7 @@ static const struct snd_soc_dapm_widget acp3x_widgets[] = { &acp3x_dmic_mux_control), };
-static const struct snd_soc_dapm_route acp3x_audio_route[] = { +static const struct snd_soc_dapm_route acp3x_5682_audio_route[] = { {"Headphone Jack", NULL, "HPOL"}, {"Headphone Jack", NULL, "HPOR"}, {"IN1P", NULL, "Headset Mic"}, @@ -307,23 +307,23 @@ static const struct snd_soc_dapm_route acp3x_audio_route[] = { {"Dmic Mux", "Rear Mic", "DMIC"}, };
-static const struct snd_kcontrol_new acp3x_mc_controls[] = { +static const struct snd_kcontrol_new acp3x_5682_mc_controls[] = { SOC_DAPM_PIN_SWITCH("Headphone Jack"), SOC_DAPM_PIN_SWITCH("Spk"), SOC_DAPM_PIN_SWITCH("Headset Mic"), };
-static struct snd_soc_card acp3x_card = { +static struct snd_soc_card acp3x_5682 = { .name = "acp3xalc5682m98357", .owner = THIS_MODULE, .dai_link = acp3x_dai_5682_98357, .num_links = ARRAY_SIZE(acp3x_dai_5682_98357), - .dapm_widgets = acp3x_widgets, - .num_dapm_widgets = ARRAY_SIZE(acp3x_widgets), - .dapm_routes = acp3x_audio_route, - .num_dapm_routes = ARRAY_SIZE(acp3x_audio_route), - .controls = acp3x_mc_controls, - .num_controls = ARRAY_SIZE(acp3x_mc_controls), + .dapm_widgets = acp3x_5682_widgets, + .num_dapm_widgets = ARRAY_SIZE(acp3x_5682_widgets), + .dapm_routes = acp3x_5682_audio_route, + .num_dapm_routes = ARRAY_SIZE(acp3x_5682_audio_route), + .controls = acp3x_5682_mc_controls, + .num_controls = ARRAY_SIZE(acp3x_5682_mc_controls), };
static int acp3x_probe(struct platform_device *pdev) @@ -336,8 +336,8 @@ static int acp3x_probe(struct platform_device *pdev) if (!machine) return -ENOMEM;
- card = &acp3x_card; - acp3x_card.dev = &pdev->dev; + card = &acp3x_5682; + acp3x_5682.dev = &pdev->dev; platform_set_drvdata(pdev, card); snd_soc_card_set_drvdata(card, machine);
@@ -348,11 +348,11 @@ static int acp3x_probe(struct platform_device *pdev) return PTR_ERR(dmic_sel); }
- ret = devm_snd_soc_register_card(&pdev->dev, &acp3x_card); + ret = devm_snd_soc_register_card(&pdev->dev, &acp3x_5682); if (ret) { dev_err(&pdev->dev, "devm_snd_soc_register_card(%s) failed: %d\n", - acp3x_card.name, ret); + acp3x_5682.name, ret); return ret; } return 0;
On Tue, 28 Jul 2020 21:32:51 +0530, Ravulapati Vishnu vardhan rao wrote:
As in future our machine driver supports multiple codecs So changing naming convention of snd_soc_card struct and its fields.
Applied to
https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next
Thanks!
[1/5] ASoC: amd: Renaming snd-soc-card structure and fields commit: 9c04b5a48fca1facff07f28ba6d87de900238beb [2/5] ASoC: amd: Passing card structure based on codec commit: 0fe4b561f7df6c338c6f4c95ba949fc5abe5c4e5 [3/5] ASoC: amd: Adding support for ALC1015 codec in machine driver commit: 414e3cab7d3e60395d23f76acdf95d5d81425b48 [4/5] ASoC: amd: Adding DAI LINK for rt1015 codec commit: f7b2651b96717f54d666a61aa3fa0b3d4e79d81a [5/5] ASoC: amd: Added hw_params support for ALC1015 commit: c3936ba9e0e4f472221320c33e20be3a8b795616
All being well this means that it will be integrated into the linux-next tree (usually sometime in the next 24 hours) and sent to Linus during the next merge window (or sooner if it is a bug fix), however if problems are discovered then the patch may be dropped or reverted.
You may get further e-mails resulting from automated or manual testing and review of the tree, please engage with people reporting problems and send followup patches addressing any issues that are reported if needed.
If any updates are required or you are submitting further changes they should be sent as incremental updates against current git, existing patches will not be replaced.
Please add any relevant lists and maintainers to the CCs when replying to this mail.
Thanks, Mark
participants (2)
-
Mark Brown
-
Ravulapati Vishnu vardhan rao