[PATCH -next] ASoC: wm8962: Use DEVICE_ATTR_WO macro
Use DEVICE_ATTR_WO() helper instead of plain DEVICE_ATTR(), which makes the code a bit shorter and easier to read.
Signed-off-by: YueHaibing yuehaibing@huawei.com --- sound/soc/codecs/wm8962.c | 7 +++---- 1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/sound/soc/codecs/wm8962.c b/sound/soc/codecs/wm8962.c index 34080f497584..ba16bdf9e478 100644 --- a/sound/soc/codecs/wm8962.c +++ b/sound/soc/codecs/wm8962.c @@ -3219,9 +3219,8 @@ static int wm8962_beep_event(struct input_dev *dev, unsigned int type, return 0; }
-static ssize_t wm8962_beep_set(struct device *dev, - struct device_attribute *attr, - const char *buf, size_t count) +static ssize_t beep_store(struct device *dev, struct device_attribute *attr, + const char *buf, size_t count) { struct wm8962_priv *wm8962 = dev_get_drvdata(dev); long int time; @@ -3236,7 +3235,7 @@ static ssize_t wm8962_beep_set(struct device *dev, return count; }
-static DEVICE_ATTR(beep, 0200, NULL, wm8962_beep_set); +static DEVICE_ATTR_WO(beep);
static void wm8962_init_beep(struct snd_soc_component *component) {
On Mon, May 24, 2021 at 07:47:53PM +0800, YueHaibing wrote:
Use DEVICE_ATTR_WO() helper instead of plain DEVICE_ATTR(), which makes the code a bit shorter and easier to read.
Signed-off-by: YueHaibing yuehaibing@huawei.com
Acked-by: Charles Keepax ckeepax@opensource.cirrus.com
Thanks, Charles
From: Mark Brown,,, broonie@kernel.org
On Mon, 24 May 2021 19:47:53 +0800, YueHaibing wrote:
Use DEVICE_ATTR_WO() helper instead of plain DEVICE_ATTR(), which makes the code a bit shorter and easier to read.
Applied, thanks!
[1/1] ASoC: wm8962: Use DEVICE_ATTR_WO macro commit: d04260393ea0ded33448c1fae944cf86c14da994
Best regards,
participants (3)
-
Charles Keepax
-
Mark Brown
-
YueHaibing