[alsa-devel] [PATCH] ALSA: riptide: Use DIV_ROUND_UP
The kernel.h macro DIV_ROUND_UP performs the computation (((n) + (d) - 1) /(d)) but is perhaps more readable.
The Coccinelle script used to make this change is as follows: @haskernel@ @@
#include <linux/kernel.h>
@depends on haskernel@ expression n,d; @@
( - (n + d - 1) / d + DIV_ROUND_UP(n,d) | - (n + (d - 1)) / d + DIV_ROUND_UP(n,d) )
Signed-off-by: Amitoj Kaur Chawla amitoj1606@gmail.com --- sound/pci/riptide/riptide.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/sound/pci/riptide/riptide.c b/sound/pci/riptide/riptide.c index 94639d6..067a912 100644 --- a/sound/pci/riptide/riptide.c +++ b/sound/pci/riptide/riptide.c @@ -1496,7 +1496,7 @@ static int snd_riptide_prepare(struct snd_pcm_substream *substream) f = PAGE_SIZE; while ((size + (f >> 1) - 1) <= (f << 7) && (f << 1) > period) f = f >> 1; - pages = (size + f - 1) / f; + pages = DIV_ROUND_UP(size, f); data->size = size; data->pages = pages; snd_printdd
On Jun 29 2016 23:56, Amitoj Kaur Chawla wrote:
The kernel.h macro DIV_ROUND_UP performs the computation (((n) + (d) - 1) /(d)) but is perhaps more readable.
The Coccinelle script used to make this change is as follows: @haskernel@ @@
#include <linux/kernel.h>
@depends on haskernel@ expression n,d; @@
(
- (n + d - 1) / d
- DIV_ROUND_UP(n,d)
|
- (n + (d - 1)) / d
- DIV_ROUND_UP(n,d)
)
Signed-off-by: Amitoj Kaur Chawla amitoj1606@gmail.com
sound/pci/riptide/riptide.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/sound/pci/riptide/riptide.c b/sound/pci/riptide/riptide.c index 94639d6..067a912 100644 --- a/sound/pci/riptide/riptide.c +++ b/sound/pci/riptide/riptide.c @@ -1496,7 +1496,7 @@ static int snd_riptide_prepare(struct snd_pcm_substream *substream) f = PAGE_SIZE; while ((size + (f >> 1) - 1) <= (f << 7) && (f << 1) > period) f = f >> 1;
pages = (size + f - 1) / f;
data->size = size; data->pages = pages; snd_printddpages = DIV_ROUND_UP(size, f);
Reviewed-by: Takashi Sakamoto o-takashi@sakamocchi.jp
Regards
Takashi Sakamoto
On Wed, 29 Jun 2016 16:56:28 +0200, Amitoj Kaur Chawla wrote:
The kernel.h macro DIV_ROUND_UP performs the computation (((n) + (d) - 1) /(d)) but is perhaps more readable.
The Coccinelle script used to make this change is as follows: @haskernel@ @@
#include <linux/kernel.h>
@depends on haskernel@ expression n,d; @@
(
- (n + d - 1) / d
- DIV_ROUND_UP(n,d)
|
- (n + (d - 1)) / d
- DIV_ROUND_UP(n,d)
)
Signed-off-by: Amitoj Kaur Chawla amitoj1606@gmail.com
Applied, thanks.
Takashi
participants (3)
-
Amitoj Kaur Chawla
-
Takashi Iwai
-
Takashi Sakamoto