[alsa-devel] ASoC updates for 2.6.37
The following changes since commit 3e13f65e3aa51fc7009afc554683a0b182c057f5:
ASoC: adapt multi-componentism again (2010-09-23 07:41:37 +0200)
are available in the git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound-2.6.git for-2.6.37
Dimitris Papastamos (3): ASoC: Delegate to hw specific read for volatile registers ASoC: Fix incorrect parameter to snd_soc_codec_volatile_register ASoC: WM8985: Remove unneeded declaration.
Mark Brown (8): ASoC: Remove unneeded WM9713 header include from SMDK WM9713 driver ASoC: Clarify naming for SMDK WM9713 driver ASoC: Clean up the CODEC device as well as the board for SMDK WM9713 ASoC: Convert s3c-ac97 to pr_() macros ASoC: Add debug logging for s3c-ac97 resets ASoC: Clean up AC'97 glue driver ASoC: Add Jassi Brar as Samsung maintainer Merge branch 'for-2.6.36' into for-2.6.37
MAINTAINERS | 6 +++ sound/soc/codecs/ac97.c | 14 +++----- sound/soc/codecs/wm8985.c | 2 - sound/soc/s3c24xx/s3c-ac97.c | 14 +++++--- sound/soc/s3c24xx/smdk_wm9713.c | 4 +- sound/soc/soc-cache.c | 76 +++++++++++++++++++++++++------------- 6 files changed, 72 insertions(+), 44 deletions(-)
At Sun, 26 Sep 2010 17:24:30 -0700, Mark Brown wrote:
The following changes since commit 3e13f65e3aa51fc7009afc554683a0b182c057f5:
ASoC: adapt multi-componentism again (2010-09-23 07:41:37 +0200)
are available in the git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound-2.6.git for-2.6.37
Dimitris Papastamos (3): ASoC: Delegate to hw specific read for volatile registers ASoC: Fix incorrect parameter to snd_soc_codec_volatile_register ASoC: WM8985: Remove unneeded declaration.
Mark Brown (8): ASoC: Remove unneeded WM9713 header include from SMDK WM9713 driver ASoC: Clarify naming for SMDK WM9713 driver ASoC: Clean up the CODEC device as well as the board for SMDK WM9713 ASoC: Convert s3c-ac97 to pr_() macros ASoC: Add debug logging for s3c-ac97 resets ASoC: Clean up AC'97 glue driver ASoC: Add Jassi Brar as Samsung maintainer Merge branch 'for-2.6.36' into for-2.6.37
Pulled now. I got a compile warning, and fixed manually with the patch below (applied to topic/asoc branch).
thanks,
Takashi
=== From cf1ff5011614cad540fa872b46552d078b510c38 Mon Sep 17 00:00:00 2001 From: Takashi Iwai tiwai@suse.de Date: Mon, 27 Sep 2010 08:13:25 +0200 Subject: [PATCH] ASoC: Fix a compile warning for printk format
sound/soc/codecs/wm8985.c: In function 'wm8985_hw_params': sound/soc/codecs/wm8985.c:731:2: warning: format '%d' expects type 'int', but argument 4 has type 'size_t'
Actually the variable is fine as int.
Signed-off-by: Takashi Iwai tiwai@suse.de --- sound/soc/codecs/wm8985.c | 2 +- 1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/sound/soc/codecs/wm8985.c b/sound/soc/codecs/wm8985.c index b94af96..6658c94 100644 --- a/sound/soc/codecs/wm8985.c +++ b/sound/soc/codecs/wm8985.c @@ -644,7 +644,7 @@ static int wm8985_hw_params(struct snd_pcm_substream *substream, struct snd_pcm_hw_params *params, struct snd_soc_dai *dai) { - size_t i; + int i; struct snd_soc_codec *codec; struct wm8985_priv *wm8985; u16 blen, srate_idx;
sound/soc/codecs/wm8985.c: In function 'wm8985_hw_params': sound/soc/codecs/wm8985.c:731:2: warning: format '%d' expects type 'int', but argument 4 has type 'size_t'
Actually the variable is fine as int.
I'd guess the expected fix is to change '%d' to '%zu'. The reason for it being size_t is that is used in an expression involving ARRAY_SIZE(...) which uses sizeof. But it does not really matter in actual fact because the array will never be large enough to cause sign confusion.
Thanks, Dimitrios
At Mon, 27 Sep 2010 09:21:14 +0100, Dimitris Papastamos wrote:
sound/soc/codecs/wm8985.c: In function 'wm8985_hw_params': sound/soc/codecs/wm8985.c:731:2: warning: format '%d' expects type 'int', but argument 4 has type 'size_t'
Actually the variable is fine as int.
I'd guess the expected fix is to change '%d' to '%zu'. The reason for it being size_t is that is used in an expression involving ARRAY_SIZE(...) which uses sizeof. But it does not really matter in actual fact because the array will never be large enough to cause sign confusion.
Yeah, I do understand the initial intention, but size_t for such a case (just for an index of a small fixed size array) is obviously too much. If it must be size_t, it shouldn't be a variable name like "i" but a more specific name.
thanks,
Takashi
On Mon, 2010-09-27 at 10:30 +0200, Takashi Iwai wrote:
Yeah, I do understand the initial intention, but size_t for such a case (just for an index of a small fixed size array) is obviously too much. If it must be size_t, it shouldn't be a variable name like "i" but a more specific name.
I see your point. Makes sense.
Cheers, Dimitrios
participants (3)
-
Dimitris Papastamos
-
Mark Brown
-
Takashi Iwai