[PATCH -next] ASoC: cs42l52: use DEVICE_ATTR_WO macro
Use DEVICE_ATTR_WO() helper instead of plain DEVICE_ATTR(), which makes the code a bit shorter and easier to read.
Signed-off-by: YueHaibing yuehaibing@huawei.com --- sound/soc/codecs/cs42l52.c | 7 +++---- 1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/sound/soc/codecs/cs42l52.c b/sound/soc/codecs/cs42l52.c index 88547e2cd53d..80161151b3f2 100644 --- a/sound/soc/codecs/cs42l52.c +++ b/sound/soc/codecs/cs42l52.c @@ -957,9 +957,8 @@ static int cs42l52_beep_event(struct input_dev *dev, unsigned int type, return 0; }
-static ssize_t cs42l52_beep_set(struct device *dev, - struct device_attribute *attr, - const char *buf, size_t count) +static ssize_t beep_store(struct device *dev, struct device_attribute *attr, + const char *buf, size_t count) { struct cs42l52_private *cs42l52 = dev_get_drvdata(dev); long int time; @@ -974,7 +973,7 @@ static ssize_t cs42l52_beep_set(struct device *dev, return count; }
-static DEVICE_ATTR(beep, 0200, NULL, cs42l52_beep_set); +static DEVICE_ATTR_WO(beep);
static void cs42l52_init_beep(struct snd_soc_component *component) {
On Mon, May 24, 2021 at 07:42:39PM +0800, YueHaibing wrote:
Use DEVICE_ATTR_WO() helper instead of plain DEVICE_ATTR(), which makes the code a bit shorter and easier to read.
Signed-off-by: YueHaibing yuehaibing@huawei.com
Reviewed-by: Charles Keepax ckeepax@opensource.cirrus.com
Thanks, Charles
From: Mark Brown,,, broonie@kernel.org
On Mon, 24 May 2021 19:42:39 +0800, YueHaibing wrote:
Use DEVICE_ATTR_WO() helper instead of plain DEVICE_ATTR(), which makes the code a bit shorter and easier to read.
Applied, thanks!
[1/1] ASoC: cs42l52: use DEVICE_ATTR_WO macro commit: 058efb40641845432c52777443b3372dbc97c032
Best regards,
participants (3)
-
Charles Keepax
-
Mark Brown
-
YueHaibing