[alsa-devel] [PATCH]
Hi,
For codec conexant 5045, I found that the name of "Capture Source Items" is different from the name of mixer.
The mixer is: HDA_CODEC_VOLUME("Ext Mic Playback Volume", 0x17, 0x2, HDA_INPUT), HDA_CODEC_MUTE("Ext Mic Playback Switch", 0x17, 0x2, HDA_INPUT),
But the capture source item is : static struct hda_input_mux cxt5045_capture_source = { .num_items = 2, .items = { { "IntMic", 0x1 }, { "LineIn", 0x2 }, } };
I think that it's better to change the name of capture_source to avoid misunderstanding.
Best regards!
Signed-off-by: Jiang zhe zhe.jiang@intel.com --- alsa-driver-hg20080115/alsa-kernel/pci/hda/patch_conexant.c 2008-01-09 09:00:15.000000000 +0800 +++ b/alsa-kernel/pci/hda/patch_conexant.c 2008-01-17 10:50:06.000000000 +0800 @@ -453,7 +453,7 @@ static struct hda_input_mux cxt5045_capt .num_items = 2, .items = { { "IntMic", 0x1 }, - { "LineIn", 0x2 }, + { "ExtMic", 0x2 }, } };
At Thu, 17 Jan 2008 10:58:04 +0800, Jiang zhe wrote:
Hi,
For codec conexant 5045, I found that the name of "Capture Source Items" is different from the name of mixer.
The mixer is: HDA_CODEC_VOLUME("Ext Mic Playback Volume", 0x17, 0x2, HDA_INPUT), HDA_CODEC_MUTE("Ext Mic Playback Switch", 0x17, 0x2, HDA_INPUT),
But the capture source item is : static struct hda_input_mux cxt5045_capture_source = { .num_items = 2, .items = { { "IntMic", 0x1 }, { "LineIn", 0x2 }, } };
I think that it's better to change the name of capture_source to avoid misunderstanding.
Best regards!
Signed-off-by: Jiang zhe zhe.jiang@intel.com
Applied this, too. Thanks.
Takashi
participants (2)
-
Jiang zhe
-
Takashi Iwai