[alsa-devel] [PATCH] Remove an obsolete macro in configure.in
From: Olivier Langlois olivier@trillion01.com
Replaced AM_CONFIG_HEADER with AC_CONFIG_HEADERS
lano1106@whippet2 ~/dev/alsa-lib $ ./gitcompile aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in' configure.in:56: error: 'AM_CONFIG_HEADER': this macro is obsolete. You should use the 'AC_CONFIG_HEADERS' macro instead. /usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from... configure.in:56: the top level autom4te: /usr/bin/m4 failed with exit status: 1 aclocal: error: echo failed with exit status: 1
Signed-off-by: Olivier Langlois olivier@trillion01.com
diff --git a/configure.in b/configure.in index ed3fe04..207e154 100644 --- a/configure.in +++ b/configure.in @@ -53,7 +53,7 @@ CC_NOUNDEFINED
dnl Checks for header files. AC_HEADER_STDC -AM_CONFIG_HEADER(include/config.h) +AC_CONFIG_HEADERS(include/config.h)
dnl Checks for typedefs, structures, and compiler characteristics. AC_C_CONST
At Thu, 16 May 2013 04:32:58 -0400, olivier@trillion01.com wrote:
From: Olivier Langlois olivier@trillion01.com
Replaced AM_CONFIG_HEADER with AC_CONFIG_HEADERS
lano1106@whippet2 ~/dev/alsa-lib $ ./gitcompile aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in' configure.in:56: error: 'AM_CONFIG_HEADER': this macro is obsolete. You should use the 'AC_CONFIG_HEADERS' macro instead. /usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from... configure.in:56: the top level autom4te: /usr/bin/m4 failed with exit status: 1 aclocal: error: echo failed with exit status: 1
Sigh, automake should be renamed to automasochism...
Signed-off-by: Olivier Langlois olivier@trillion01.com
Thanks, applied.
BTW, at the next time, please specify which package to patch :)
Takashi
diff --git a/configure.in b/configure.in index ed3fe04..207e154 100644 --- a/configure.in +++ b/configure.in @@ -53,7 +53,7 @@ CC_NOUNDEFINED
dnl Checks for header files. AC_HEADER_STDC -AM_CONFIG_HEADER(include/config.h) +AC_CONFIG_HEADERS(include/config.h)
dnl Checks for typedefs, structures, and compiler characteristics. AC_C_CONST -- 1.8.2.3
Sigh, automake should be renamed to automasochism...
Signed-off-by: Olivier Langlois olivier@trillion01.com
Thanks, applied.
BTW, at the next time, please specify which package to patch :)
Takashi,
I am not asking better than improve my patch submitting skill. Please explain exactly what was missing. I followed what is described at
http://www.alsa-project.org/main/index.php/GIT_Server
When you say package was missing, are you referring to 'my module' in:
git format-patch -s -n -p --subject-prefix="PATCH - my module" remotes/origin/master
and in this particular case should 'my module' be configure or alsa-lib or something else?
Thank you, Olivier
________________________________ CONFIDENTIALITY : This e-mail and any attachments are confidential and may be privileged. If you are not a named recipient, please notify the sender immediately and do not disclose the contents to another person, use it for any purpose or store or copy the information in any medium.
At Thu, 16 May 2013 15:07:04 +0000, LANGLOIS Olivier PIS -EXT wrote:
Sigh, automake should be renamed to automasochism...
Signed-off-by: Olivier Langlois olivier@trillion01.com
Thanks, applied.
BTW, at the next time, please specify which package to patch :)
Takashi,
I am not asking better than improve my patch submitting skill. Please explain exactly what was missing. I followed what is described at
http://www.alsa-project.org/main/index.php/GIT_Server
When you say package was missing, are you referring to 'my module' in:
git format-patch -s -n -p --subject-prefix="PATCH - my module" remotes/origin/master
and in this particular case should 'my module' be configure or alsa-lib or something else?
You need to give two things, one is the repository to apply (alsa-lib, alsa-utils, etc) and another (optionally) is the internal component in the repo (pcm, configure, aplay, whatever). The former is usually included in "[PATCH xxx]" form, which is omitted when applied via git-am. So in the git commit, this won't be tracked. It's needed only to indicate which repo to apply.
The second, optional component part is usually given as a suffix following colon. So, in your case, a better subject line would have been something like:
[PATCH alsa-lib] configure: remove an obsolete macro
thanks,
Takashi
Hi,
El dj 16 de 05 de 2013 a les 15:47 +0200, en/na Takashi Iwai va escriure:
At Thu, 16 May 2013 04:32:58 -0400, olivier@trillion01.com wrote:
From: Olivier Langlois olivier@trillion01.com
Replaced AM_CONFIG_HEADER with AC_CONFIG_HEADERS
lano1106@whippet2 ~/dev/alsa-lib $ ./gitcompile aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in' configure.in:56: error: 'AM_CONFIG_HEADER': this macro is obsolete. You should use the 'AC_CONFIG_HEADERS' macro instead. /usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from... configure.in:56: the top level autom4te: /usr/bin/m4 failed with exit status: 1 aclocal: error: echo failed with exit status: 1
Sigh, automake should be renamed to automasochism...
Would you accept patches for some other improvements, like generating xz tarballs and modernising some bits of the autotools infrastructure?
In particular, if wanted, getting rid of the package-of-packages layout in alsa-tools and have it be a single package with a single configure script like alsa-utils is something I'd like to get done in my copious free time.
Jordi
At Mon, 27 May 2013 17:00:50 +0200, Jordi Mallach wrote:
Hi,
El dj 16 de 05 de 2013 a les 15:47 +0200, en/na Takashi Iwai va escriure:
At Thu, 16 May 2013 04:32:58 -0400, olivier@trillion01.com wrote:
From: Olivier Langlois olivier@trillion01.com
Replaced AM_CONFIG_HEADER with AC_CONFIG_HEADERS
lano1106@whippet2 ~/dev/alsa-lib $ ./gitcompile aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in' configure.in:56: error: 'AM_CONFIG_HEADER': this macro is obsolete. You should use the 'AC_CONFIG_HEADERS' macro instead. /usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from... configure.in:56: the top level autom4te: /usr/bin/m4 failed with exit status: 1 aclocal: error: echo failed with exit status: 1
Sigh, automake should be renamed to automasochism...
Would you accept patches for some other improvements, like generating xz tarballs and modernising some bits of the autotools infrastructure?
In particular, if wanted, getting rid of the package-of-packages layout in alsa-tools and have it be a single package with a single configure script like alsa-utils is something I'd like to get done in my copious free time.
I myself don't mind any changes, but don't know what other people think. I guess the current structure of alsa-tools was done so that you can build some of alsa-tools components even without the installation of full dependent packages.
This was the era before pkgconfig, and auto-tools required the explicit macro definitions of the dependent packages. With pkgconfig, this is no longer true, so it'd be OK to unify, but let's see...
In anyway, just send patches if you think they are good.
thanks,
Takashi
participants (4)
-
Jordi Mallach
-
LANGLOIS Olivier PIS -EXT
-
olivier@trillion01.com
-
Takashi Iwai