On Wed, 2020-02-26 at 15:40 +0900, Kuninori Morimoto wrote:
From: Kuninori Morimoto kuninori.morimoto.gx@renesas.com
dpcm_fe_dai_close() and error case of dpcm_fe_dai_open() need to do same cleanup operation. To avoid duplicate code, this patch adds dpcm_fe_dai_clean() and use it.
Signed-off-by: Kuninori Morimoto kuninori.morimoto.gx@renesas.com
sound/soc/soc-pcm.c | 30 ++++++++++++++++-------------- 1 file changed, 16 insertions(+), 14 deletions(-)
diff --git a/sound/soc/soc-pcm.c b/sound/soc/soc-pcm.c index 3686dda097e2..d578dbdfa846 100644 --- a/sound/soc/soc-pcm.c +++ b/sound/soc/soc-pcm.c @@ -2978,14 +2978,11 @@ int soc_dpcm_runtime_update(struct snd_soc_card *card) return ret; }
-static int dpcm_fe_dai_close(struct snd_pcm_substream *fe_substream) +static void dpcm_fe_dai_clean(struct snd_pcm_substream *fe_substream)
The series looks good to me, Morimoto-san. But a minor suggestion if you're doing a v2 to address other comments. Could you please change the name of the function above to dpcm_fe_dai_cleanup() instead?
Reviewed-by: Ranjani Sridharan ranjani.sridharan@linux.intel.com
Thanks, Ranjani