At Thu, 14 Feb 2013 14:12:51 +0530, Vinod Koul wrote:
this add new API for sound compress to support gapless playback. As noted in Documentation change, we add API to send metadata of encoder and padding delay to DSP. Also add API for indicating EOF and switching to subsequent track
Also bump the compress API version
Signed-off-by: Jeeja KP jeeja.kp@intel.com Signed-off-by: Vinod Koul vinod.koul@intel.com
v5:
- update metadata value with 8 words
What's the reason behind this change? I can think of metadata like EQ parameters, but the magic number 8 is in question :)
I'm no enthusiastic over minimalism like Apple, so I don't mind this change, but just out of curiosity...
Also, another spot:
@@ -145,6 +160,10 @@ struct snd_compr_codec_caps { struct snd_compr_codec_caps) #define SNDRV_COMPRESS_SET_PARAMS _IOW('C', 0x12, struct snd_compr_params) #define SNDRV_COMPRESS_GET_PARAMS _IOR('C', 0x13, struct snd_codec) +#define SNDRV_COMPRESS_SET_METADATA _IOW('C', 0x14,\
struct snd_compr_metadata)
+#define SNDRV_COMPRESS_GET_METADATA _IOW('C', 0x15,\
struct snd_compr_metadata)
Isn't it _IOWR()?
Takashi