Hi,
thanks! I tested this on a few machines and seems good, no functional issues.
On Thu, 25 Feb 2021, Hui Wang wrote:
--- a/sound/pci/hda/patch_hdmi.c +++ b/sound/pci/hda/patch_hdmi.c @@ -157,6 +157,7 @@ struct hdmi_spec {
bool dyn_pin_out; bool dyn_pcm_assign;
- bool no_fixed_assign;
hmm, I wonder if we could come up with a better name. "dyn_pcm_assign" and "no_fixed_assign" seem a bit at odds.
How about: bool dyn_pcm_assign; + bool dyn_pcm_no_legacy;
Then it's more clear this is still the same dynamic PCM assign policy, but we just drop the legacy exception.
Takashi, do you think we can go with this without any method (a module option) to opt-out?
I'm ok to go with this, given all users should be using kcontrol status to select the PCM for HDMI/DP output. Any other method is not guaranteed anyways to work in all cases as the assignment is dynamic in the end..
Br, Kai