23 Mar
2020
23 Mar
'20
5:38 p.m.
On Fri, Mar 20, 2020 at 09:32:26PM +0100, Thomas Gleixner wrote:
Andy Shevchenko andy.shevchenko@gmail.com writes:
On Fri, Mar 20, 2020 at 3:19 PM Thomas Gleixner tglx@linutronix.de wrote:
The new macro set has a consistent namespace and uses C99 initializers instead of the grufty C89 ones.
Rename the local macro wrapper to X86_MATCH for consistency. It stays for readability sake.
X86_MATCH_INTEL_FAM6_MODEL(ATOM_SILVERMONT, NULL),
X86_MATCH_INTEL_FAM6_MODEL(ATOM_AIRMONT, NULL),
-#define ICPU(model) { X86_VENDOR_INTEL, 6, model, X86_FEATURE_ANY, } +#define X86_MATCH(model) X86_MATCH_INTEL_FAM6_MODEL(model, NULL)
Maybe we can do a generic macro to avoid all these ', NULL' repetitions?
I opted for having the data argument everywhere to keep the macro maze small. And we have enough places where data is actually used.
+1
--mark
Thanks,
tglx