4 Mar
2021
4 Mar
'21
11:06 p.m.
Hi Mark
-static bool soc_pcm_has_symmetry(struct snd_pcm_substream *substream) +static void soc_pcm_care_symmetry(struct snd_pcm_substream *substream) { struct snd_soc_pcm_runtime *rtd = asoc_substream_to_rtd(substream); struct snd_soc_dai_link *link = rtd->dai_link; @@ -423,7 +423,8 @@ static bool soc_pcm_has_symmetry(struct snd_pcm_substream *substream) dai->driver->symmetric_channels || dai->driver->symmetric_sample_bits;
- return symmetry;
- if (symmetry)
substream->runtime->hw.info |= SNDRV_PCM_INFO_JOINT_DUPLEX;
The idea makes sense but I'm not sure about the name here - perhaps soc_pcm_update_symmetry() might work better? It's not super clear but does look more natural.
Thank for your feedback. Make sense, will update today
Thank you for your help !!
Best regards --- Kuninori Morimoto