+int q6apm_read(struct q6apm_graph *graph) +{ + struct data_cmd_rd_sh_mem_ep_data_buffer_v2 *read; + struct audioreach_graph_data *port; + struct audio_buffer *ab; + struct gpr_pkt *pkt; + int rc, iid;
+ iid = q6apm_graph_get_tx_shmem_module_iid(graph); + pkt = audioreach_alloc_pkt(sizeof(*read), DATA_CMD_RD_SH_MEM_EP_DATA_BUFFER_V2, + graph->tx_data.dsp_buf, graph->port->id, iid); + if (IS_ERR(pkt)) + return -ENOMEM;
+ read = (void *)pkt + GPR_HDR_SIZE;
same nit-pick on variable naming, with the additional present/past grammar issue that you don't know if it's a read buffer or a pointer to data read in the past.
do you think adding "_cmd" suffix like read_cmd would make more sense?
My personal preference is read_buffer or write_buffer, less ambiguous than 'read' or 'write'.
I've started cracking down on the use of 'stream' for a similar reason, at some point no one know what the code/variables represent.