15 Oct
2011
15 Oct
'11
5:21 a.m.
2011/10/15 Mark Brown broonie@opensource.wolfsonmicro.com:
On Fri, Oct 14, 2011 at 05:03:07PM +0800, Axel Lin wrote:
reg = snd_soc_read(codec, AD193X_DAC_CTRL2);
- reg = (mute > 0) ? reg | AD193X_DAC_MASTER_MUTE : reg &
- (~AD193X_DAC_MASTER_MUTE);
- if (mute)
- reg |= AD193X_DAC_MASTER_MUTE;
- else
- reg &= ~AD193X_DAC_MASTER_MUTE;
snd_soc_write(codec, AD193X_DAC_CTRL2, reg);
This is still using snd_soc_read() and snd_soc_write() (though it is a cleanup).
hi Mark, One of the major reason that I do the convert to snd_soc_update_bits is for better readability. In this case, it seems ok to me with this change. But if you prefer also convert it to snd_soc_update_bits, I can do it. Let me know if I need to send a v2 for it.
Thanks, Axel