21 Feb
2022
21 Feb
'22
4:24 p.m.
On Mon, Feb 21, 2022 at 01:10:28PM +0000, Srinivas Kandagatla wrote:
+static int __maybe_unused va_macro_runtime_resume(struct device *dev) +{
- struct va_macro *va = dev_get_drvdata(dev);
- clk_prepare_enable(va->clks[2].clk);
This magic number stuff is going to be excessively fragile, and the fact that this is sometimes managed via the bulk APIs and sometimes not isn't going to help either. Either all the clocks should be managed here or this should be pulled out of the array.
Also consider error checking.