On 2020-01-27 22:20, Pierre-Louis Bossart wrote:
diff --git a/sound/soc/sof/sof-priv.h b/sound/soc/sof/sof-priv.h index bc2337cf1142..9fa6fb6c7b93 100644 --- a/sound/soc/sof/sof-priv.h +++ b/sound/soc/sof/sof-priv.h @@ -387,6 +387,9 @@ struct snd_sof_dev { wait_queue_head_t waitq; int code_loading; + /* probes */ + unsigned int extractor;
if we can rename this extractor_stream_tag it'd be more explicit for future code evolutions. we have too many things in this sof-dev structures and it's hard to keep track of what is used for what without self-explanatory naming conventions. Thanks!
Renamed as requested.
Whether directly or indirectly, your comments made me realize the 'extractor_stream_tag' field was incorrectly declared within 07 (this patch) rather than the 08 patch: "ASoC: SOF: Generic probe compress operations". Said field never enters IPC domain and is opaque towards probe-IPCs. Only the compress related mechanism cares about it. Thanks Pierre!
Czarek