On Wednesday 10 December 2008 10:27:44 ext stanley.miao wrote:
On Tue, 2008-12-09 at 14:01 +0000, Mark Brown wrote:
From: Peter Ujfalusi peter.ujfalusi@nokia.com
Adds DAPM muxing, routing for the Headset outputs.
Signed-off-by: Peter Ujfalusi peter.ujfalusi@nokia.com Signed-off-by: Mark Brown broonie@opensource.wolfsonmicro.com
sound/soc/codecs/twl4030.c | 39 +++++++++++++++++++++++++++++++++++++++ 1 files changed, 39 insertions(+), 0 deletions(-)
<snip>
SND_SOC_DAPM_ADC("ADCL", "Left Capture", SND_SOC_NOPM, 0, 0), SND_SOC_DAPM_ADC("ADCR", "Right Capture", SND_SOC_NOPM, 0, 0), @@ -744,6 +775,12 @@ static const struct snd_soc_dapm_route intercon[] = { {"PredriveR Mux", "DACR1", "ARXR1_APGA"}, {"PredriveR Mux", "DACR2", "ARXR2_APGA"}, {"PredriveR Mux", "DACL2", "ARXL2_APGA"},
- /* HeadsetL */
- {"HeadsetL Mux", "DACL1", "ARXL1_APGA"},
- {"HeadsetL Mux", "DACL2", "ARXL2_APGA"},
The control names "DACR1","DACR2","DACL1","DACL2" have the same name with the widgets in the first patch. I suggest you change a different name to avoid confusion.
Yes, this can be confusing... I'm thinking of changing either the control names like this: "DACR1" -> "DAC Right1" or "Audio Out R1" or "Out R1" "DACR2" -> "DAC Right2" or "Audio Out R2" or "Out R1" ... I think the "DAC Right1" type reflects better the functionality of the mux...
or make the same name change, but with the SND_SOC_DAPM_DAC
Stanley.