15 Sep
2021
15 Sep
'21
5:54 p.m.
+#define APM_SHMEM_FMT_CFG_PSIZE(n) ALIGN( \
sizeof(struct apm_sh_module_media_fmt_cmd) + \
n * sizeof(uint8_t), 8)
+/* num of channels as argument */ +#define APM_PCM_MODULE_FMT_CMD_PSIZE(n) ALIGN( \
sizeof(struct apm_pcm_module_media_fmt_cmd) + \
n * sizeof(uint8_t), 8)
+#define APM_PCM_OUT_FMT_CFG_PSIZE(n) ALIGN((sizeof( \
struct payload_pcm_output_format_cfg) + \
n * sizeof(uint8_t)), 4)
nit-pick: sizeof on the same line for consistency/readability?