3 Jun
2010
3 Jun
'10
7:03 p.m.
On Thu, 2010-06-03 at 18:50 +0200, Lars-Peter Clausen wrote:
- config = snd_soc_dai_get_dma_data(rtd->dai->cpu_dai,
substream);
- if (!prtd->dma) {
const char *dma_channel_name;
if (substream->stream == SNDRV_PCM_STREAM_PLAYBACK)
dma_channel_name = "PCM Playback";
else
dma_channel_name = "PCM Capture";
prtd->dma = jz4740_dma_request(substream,
dma_channel_name);
dma_channel_name variable is not required here. Just use the const
char
- directly.
I actually had it like that before, but I think it is much more readable in its current form.
I disagree, having the char pointer here just adds an extra level of indirection and costs an extra two lines of code.
Liam
--
Freelance Developer, SlimLogic Ltd
ASoC and Voltage Regulator Maintainer.
http://www.slimlogic.co.uk