13 May
2013
13 May
'13
4:30 p.m.
Takashi Iwai wrote:
Imre Deak wrote:
Use msecs_to_jiffies_min instead of open-coding the same.
+++ b/sound/pci/oxygen/oxygen_io.c @@ -108,7 +108,7 @@ static int oxygen_ac97_wait(struct oxygen *chip, unsigned int mask) wait_event_timeout(chip->ac97_waitqueue, ({ status |= oxygen_read8(chip, OXYGEN_AC97_INTERRUPT_STATUS); status & mask; }),
msecs_to_jiffies(1) + 1);
msecs_to_jiffies_min(1));
This would change the behavior, I guess.
No, that's exactly how msecs_to_jiffies_min would be implemented.
(Though, I'm not sure whether the original code was intentional.)
When I wrote this, I was not able to prove that msecs_to_jiffies always rounds up. (And I guess it doesn't; otherwise the _min variant would not be needed.)
Regards, Clemens