
Pass the device pointer from the PCI pointer directly, instead of a non-standard macro. The macro didn't give any better readability.
Along with it, the unneeded assignment before snd_dma_alloc_pages*() call is dropped.
Signed-off-by: Takashi Iwai tiwai@suse.de --- sound/pci/es1968.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/sound/pci/es1968.c b/sound/pci/es1968.c index 974142535a25..7017ca9dea4a 100644 --- a/sound/pci/es1968.c +++ b/sound/pci/es1968.c @@ -1422,10 +1422,8 @@ snd_es1968_init_dmabuf(struct es1968 *chip) int err; struct esm_memory *chunk;
- chip->dma.dev.type = SNDRV_DMA_TYPE_DEV; - chip->dma.dev.dev = snd_dma_pci_data(chip->pci); err = snd_dma_alloc_pages_fallback(SNDRV_DMA_TYPE_DEV, - snd_dma_pci_data(chip->pci), + &chip->pci->dev, chip->total_bufsize, &chip->dma); if (err < 0 || ! chip->dma.area) { dev_err(chip->card->dev,