5 Sep
2007
5 Sep
'07
3:20 p.m.
At Wed, 05 Sep 2007 00:24:33 +0200, Rene Herman wrote:
-#if 0
- snd_printdd("WSS signature = 0x%x\n", tmp);
-#endif
Please don't just kill debug code. It's very useful for the next person stepping in -- it's "functional commentary".
Then let's get rid of "#if 0". snd_printdd() won't get compiled unless CONFIG_SND_DEBUG_DETECT is set, so there is no reason to kill twice.
@@ -327,7 +329,8 @@ static int snd_sgalaxy_resume(struct dev
chip->resume(chip); snd_ad1848_out(chip, SGALAXY_AUXC_LEFT, chip->image[SGALAXY_AUXC_LEFT]);
- snd_ad1848_out(chip, SGALAXY_AUXC_RIGHT, chip->image[SGALAXY_AUXC_RIGHT]);
- snd_ad1848_out(chip, SGALAXY_AUXC_RIGHT,
chip->image[SGALAXY_AUXC_RIGHT]);
Definitely would keep this on one line.
Well, I don't think that's too bad to fold. But, it's not forcible enough, too.
After all, the 80-chars rule is for readability, and the readability is more or less a matter of taste.
Takashi