6 Dec
2010
6 Dec
'10
11:43 p.m.
On Mon, Dec 06, 2010 at 04:34:37PM -0600, Olaya, Margarita wrote:
In some cases it was not possible to follow the appropiate power ON/OFF sequence. Add a widget to support speaker drivers where power ON/OFF ordering is important.
Why not use the existing speaker widget? It's at pretty much the same point in the sequence and is intended for use with external GPIO controlled speaker drivers. It'd be good to discuss this in the changelog.
+#define SND_SOC_DAPM_DRV(wname, wreg, wshift, winvert,\
wcontrols, wncontrols) \
+{ .id = snd_soc_dapm_drv, .name = wname, .reg = wreg, .shift = wshift, \
- .invert = winvert, .kcontrols = wcontrols, .num_kcontrols = wncontrols}
The _DRV name seems rather opaque - I'd suggest _SPK as a name but obviously that's in use. If we do want this I guess _SPK_DRV or sommething.