On Thu, 11 Nov 2021 10:19:14 +0100, shumingf@realtek.com wrote:
From: Shuming Fan shumingf@realtek.com
Add the profile name to let userspace pick correct UCM profile
Was the corresponding change for alsa-ucm-conf submitted to upstream?
Signed-off-by: Shuming Fan shumingf@realtek.com
sound/usb/card.c | 4 ++++ 1 file changed, 4 insertions(+)
diff --git a/sound/usb/card.c b/sound/usb/card.c index 1764b9302d46..9c67ecbe710e 100644 --- a/sound/usb/card.c +++ b/sound/usb/card.c @@ -398,6 +398,10 @@ static const struct usb_audio_device_name usb_audio_names[] = { PROFILE_NAME(0x0bda, 0x4014, "Dell", "WD15 Dock", "Dell-WD15-Dock"), /* Dell WD19 Dock */ PROFILE_NAME(0x0bda, 0x402e, "Dell", "WD19 Dock", "Dell-WD15-Dock"),
- /* Dell Desktop - Front */
- PROFILE_NAME(0x0bda, 0x4c54, "Dell", "Desktop", "Dell-Desktop-Front"),
- /* Dell Desktop - Rear */
- PROFILE_NAME(0x0bda, 0x4c55, "Dell", "Desktop", "Dell-Desktop-Rear"),
IMO, the profile name sounds too generic. It's better to have with some model name at least so that it can be identified more uniquely.
thanks,
Takashi