On 2022-04-01 2:01 PM, Amadeusz Sławiński wrote:
Following patches contain minor changes, cleaning up code to be easier to read. Clean up few loops, to be simpler or altogether remove them. Rename some things to make code easier to understand.
While avs-driver is not fully upstreamed yet, I believe it is still vital to state that patches have been tested on following cAVS 1.5 platforms i.e.: Skylake, Kabylake, Amberlake, Appololake and their variants with the avs-drivers.
As code looks good to me:
Reviewed-by: Cezary Rojewski cezary.rojewski@intel.com
Amadeusz Sławiński (6): ASoC: topology: Use for loop instead of while ASoC: topology: Remove unnecessary looping ASoC: topology: Return bool instead of int ASoC: topology: Rename SOC_TPLG_PASS_MIXER to _CONTROL ASoC: topology: Correct error message ASoC: topology: Rename soc_tplg_init_kcontrol() function
sound/soc/soc-topology.c | 455 ++++++++++++++++++--------------------- 1 file changed, 208 insertions(+), 247 deletions(-)