I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu chuansheng.liu@intel.com Signed-off-by: Baole Ni baolex.ni@intel.com --- sound/pci/ca0106/ca0106_main.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/sound/pci/ca0106/ca0106_main.c b/sound/pci/ca0106/ca0106_main.c index d3cd956..84ee394 100644 --- a/sound/pci/ca0106/ca0106_main.c +++ b/sound/pci/ca0106/ca0106_main.c @@ -159,13 +159,13 @@ static char *id[SNDRV_CARDS] = SNDRV_DEFAULT_STR; static bool enable[SNDRV_CARDS] = SNDRV_DEFAULT_ENABLE_PNP; static uint subsystem[SNDRV_CARDS]; /* Force card subsystem model */
-module_param_array(index, int, NULL, 0444); +module_param_array(index, int, NULL, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(index, "Index value for the CA0106 soundcard."); -module_param_array(id, charp, NULL, 0444); +module_param_array(id, charp, NULL, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(id, "ID string for the CA0106 soundcard."); -module_param_array(enable, bool, NULL, 0444); +module_param_array(enable, bool, NULL, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(enable, "Enable the CA0106 soundcard."); -module_param_array(subsystem, uint, NULL, 0444); +module_param_array(subsystem, uint, NULL, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(subsystem, "Force card subsystem model.");
#include "ca0106.h"