I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu chuansheng.liu@intel.com Signed-off-by: Baole Ni baolex.ni@intel.com --- sound/drivers/opl4/opl4_seq.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/sound/drivers/opl4/opl4_seq.c b/sound/drivers/opl4/opl4_seq.c index 03d6202..6e977cd 100644 --- a/sound/drivers/opl4/opl4_seq.c +++ b/sound/drivers/opl4/opl4_seq.c @@ -43,7 +43,7 @@ MODULE_LICENSE("Dual BSD/GPL");
int volume_boost = 8;
-module_param(volume_boost, int, 0644); +module_param(volume_boost, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(volume_boost, "Additional volume for OPL4 wavetable sounds.");
static int snd_opl4_seq_use_inc(struct snd_opl4 *opl4)