-------------------------------------------------- From: "Mark Brown" broonie@kernel.org Sent: Thursday, November 13, 2014 3:59 AM To: "Krishna Mohan Dani" krishna.md@samsung.com Cc: linux-samsung-soc@vger.kernel.org; linux-arm-kernel@lists.infradead.org; alsa-devel@alsa-project.org; kgene.kim@samsung.com Subject: Re: [PATCH 2/4 V2] ASoC: Samsung: Add arndale_rt5631 machine driver
+static struct snd_soc_card arndale = {
- .name = "Arndale-I2S",
- .dai_link = arndale_dai,
- .num_links = ARRAY_SIZE(arndale_dai),
+};
Please give the card a more specific name like "Arndale RT5631" and similarly update the symbol names, there are other modules for the Arndale board.
Ok I changed the name from "Arndale-I2S" to "Arndale-RT5631".
From the rest of the comment what I understand is you want me to change the
names of struct snd_soc_dai_link and struct snd_soc_card. Am that right? and/or do you want me to change the names whereever it sounds like generic and make it specific for arndale - rt5631 pair?