Hi Pierre-Louis
Thank you for your feedback
+SND_SOC_DAI_LINK_CCP(aif1,
- SND_SOC_DAI_LINK(SDL_CPU("samsung-i2s.0")),
- SND_SOC_DAI_LINK(SDL_CODEC("wm8994-codec", "wm8994-aif1")),
- SND_SOC_DAI_LINK(SDL_PLATFORM("samsung-i2s.0")));
(snip)
static struct snd_soc_dai_link smdk_dai[] = { { /* Primary DAI i/f */ .name = "WM8994 AIF1", .stream_name = "Pri_Dai",
.cpu_dai_name = "samsung-i2s.0",
.codec_dai_name = "wm8994-aif1",
.platform_name = "samsung-i2s.0",
.init = smdk_wm8994_init_paiftx, .dai_fmt = SND_SOC_DAIFMT_I2S | SND_SOC_DAIFMT_NB_NF | SND_SOC_DAIFMT_CBM_CFM, .ops = &smdk_ops,.codec_name = "wm8994-codec",
SND_SOC_LINK_CCP(aif1),
is this really the new direction? Even the acronyms are not simple, it took me 15mn to figure out that CCP stood for CPU/Codec/Platform and I couldn't figure out what SDL means.
The reason of "CCP" (= CPU/CODEC/PLATFORM) was to avoid long naming. and SDL is acronyms of "Snd soc Dai Link". but yes, it is un-understandable. It should be more understandable (and possibly short) naming.
The multiple repetitions of SND_SOC_DAI_LINK is also misleading, it's just a property of the *same* dailink that you handle.
it is needed to handle both single/multi CPU/Codec/Platform. But yes, it has naming issue.
I am even more nervous since we have a need to explicitly some cpu and codec dai names depending on quirks, with the additional abstraction it'll become plain unreadable - or we need new helpers.
Hmm, OK. I will reconsider about macro. I'm happy if you can review it again.
Thank you for your help !!
Best regards --- Kuninori Morimoto