23 Dec
2007
23 Dec
'07
3:23 a.m.
Lee Revell wrote:
Please use DMA_32BIT_MASK (see include/linux/dma-mapping.h) instead of 0xffffffff.
No prob. But did you see this comment:
/* * NOTE: do not use the below macros in new code and do not add new definitions * here. * * Instead, just open-code DMA_BIT_MASK(n) within your driver */
So I guess I should use DMA_BIT_MASK(32) instead.
I've personally fixed a heisenbug in an ALSA driver caused by incorrectly typed DMA mask...
Can you explain to me what all of this does? Is it okay to use a static u64 variable? Why do so many drivers do it that way? I don't even know if 0xFFFFFFFF is the right number for my platform.