26 Jul
2019
26 Jul
'19
4:09 p.m.
diff --git a/drivers/soundwire/cadence_master.c b/drivers/soundwire/cadence_master.c index 889fa2cd49ae..25d5c7267c15 100644 --- a/drivers/soundwire/cadence_master.c +++ b/drivers/soundwire/cadence_master.c @@ -643,13 +643,35 @@ static int cdns_update_slave_status(struct sdw_cdns *cdns,
/* first check if Slave reported multiple status */ if (set_status > 1) {
u32 val;
dev_warn_ratelimited(cdns->dev,
"Slave reported multiple Status: %d\n",
mask);
/*
* TODO: we need to reread the status here by
* issuing a PING cmd
*/
"Slave %d reported multiple Status: %d\n",
i, mask);
/* re-check latest status extracted from PING commands */
val = cdns_readl(cdns, CDNS_MCP_SLAVE_STAT);
val >>= (i * 2);
Superfluous parentheses.
Humm, I don't know my left from my right and I can't remember operator precedence, so i'd rather make it explicit...
switch (val & 0x3) {
case 0:
status[i] = SDW_SLAVE_UNATTACHED;
break;
case 1:
status[i] = SDW_SLAVE_ATTACHED;
break;
case 2:
status[i] = SDW_SLAVE_ALERT;
break;
default:
There aren't many values left for the "default" case :-) But I'm not sure whether any of
case 3:
or
case 3:
default:
would improve readability.
Thanks Guennadi
status[i] = SDW_SLAVE_RESERVED;
break;
Yes, those defaults are annoying. Some tools complain so I tend to leave them.