10 Mar
2016
10 Mar
'16
10:59 a.m.
Hi Mark
On Mon, Feb 22, 2016 at 4:19 AM, Mark Brown broonie@kernel.org wrote:
On Fri, Feb 05, 2016 at 06:24:57PM +0100, Michael Trimarchi wrote:
+#define PCM1795 1
unsigned int codec_model;
It looks like you're trying to define an enum here.
+static const unsigned int codec_model = PCM1795;
Ok
That's a weird name to use here. Call it pcm1795 or something, though normally we just cast the integer to and from a pointer.
{ .compatible = "ti,pcm1795",
.data = &codec_model,
},
This is strange indentation, just keep it on one line and it's easier to follow.
Ok
Michael
--
| Michael Nazzareno Trimarchi Amarula Solutions BV |
| COO - Founder Cruquiuskade 47 |
| +31(0)851119172 Amsterdam 1018 AM NL |
| [`as] http://www.amarulasolutions.com |