![](https://secure.gravatar.com/avatar/de1471d0340caa87f7662e0a028f9cd0.jpg?s=120&d=mm&r=g)
On Sat, Aug 08, 2009 at 13:41:58, Mark Brown wrote:
On Fri, Aug 07, 2009 at 10:07:42AM -0400, Chaithrika U S wrote:
This patch adds support for FIFO configuration.The platform member has a
version field which differentiates the McASP on different SoCs. The
patch
also adds another DAI format to the driver.
You really should split out the DAI format addition into another patch - there's no code overlap between that and the rest of your changes.
OK. I will post a separate patch for this change.
Aside from the issue Troy raised everything seems fine except for one
OK. I will submit a patch for that issue.
small issue:
- /* McASP FIFO related */
- u8 txnumevt;
- u8 rxnumevt;
These names don't seem particularly obvious. If they were chosen to match the datasheet name then it probably won't be a problem but otherwise something more like tx_fifo_depth might be easier for people to figure out.
Currently, the names are as per the peripheral datasheet. So, will retain the same name.
Regards, Chaithrika