18 Apr
2023
18 Apr
'23
1:07 p.m.
On 18/04/2023 14:55, Mark Brown wrote:
On Tue, Apr 18, 2023 at 09:46:27AM +0200, Krzysztof Kozlowski wrote:
Replace dev_err() in probe() path with dev_err_probe() to:
- Make code a bit simpler and easier to read,
- Do not print messages on deferred probe.
*/
wcd->intr1 = of_irq_get_byname(wcd->dev->of_node, "intr1");
- if (wcd->intr1 < 0) {
if (wcd->intr1 != -EPROBE_DEFER)
dev_err(wcd->dev, "Unable to configure IRQ\n");
return wcd->intr1;
This is already not printing a message on deferred probe.
True, but the other places in the patch don't have such condition.
Best regards, Krzysztof