
22 Feb
2016
22 Feb
'16
5:19 a.m.
On Fri, Feb 05, 2016 at 06:24:57PM +0100, Michael Trimarchi wrote:
+#define PCM1795 1
- unsigned int codec_model;
It looks like you're trying to define an enum here.
+static const unsigned int codec_model = PCM1795;
That's a weird name to use here. Call it pcm1795 or something, though normally we just cast the integer to and from a pointer.
- { .compatible = "ti,pcm1795",
.data = &codec_model,
- },
This is strange indentation, just keep it on one line and it's easier to follow.