On Wed, Jun 22, 2022 at 3:08 PM Stefan Binding sbinding@opensource.cirrus.com wrote:
Add a wrapper function to read the _SUB string from ACPI.
Signed-off-by: Stefan Binding sbinding@opensource.cirrus.com
drivers/acpi/utils.c | 26 ++++++++++++++++++++++++++ include/linux/acpi.h | 8 ++++++++ 2 files changed, 34 insertions(+)
diff --git a/drivers/acpi/utils.c b/drivers/acpi/utils.c index 3a9773a09e19..5d1bdb79e372 100644 --- a/drivers/acpi/utils.c +++ b/drivers/acpi/utils.c @@ -291,6 +291,32 @@ int acpi_get_local_address(acpi_handle handle, u32 *addr) } EXPORT_SYMBOL(acpi_get_local_address);
+int acpi_get_sub(acpi_handle handle, char *sub, size_t size)
I'd call it acpi_get_subsystem_id().
+{
struct acpi_buffer buffer = { ACPI_ALLOCATE_BUFFER, NULL };
union acpi_object *obj;
acpi_status status;
int ret;
status = acpi_evaluate_object(handle, METHOD_NAME__SUB, NULL, &buffer);
if (!ACPI_SUCCESS(status)) {
Typically, ACPI_FAILURE() is used in checks like this.
acpi_handle_debug(handle, "Reading ACPI _SUB failed: %#x\n", status);
It would be enough to say "_SUB evaluation failed".
return -ENOENT;
Why not use -ENODATA here?
}
obj = buffer.pointer;
if (obj->type == ACPI_TYPE_STRING) {
ret = strscpy(sub, obj->string.pointer, size);
It may be simpler to allocate the memory here so that callers don't have to worry about it.
Also, this is expected to be a proper device ID, not just a string, so maybe some validation checks could be made here?
} else {
acpi_handle_warn(handle, "Warning ACPI _SUB did not return a string\n");
ret = -EINVAL;
}
acpi_os_free(buffer.pointer);
return ret;
+} +EXPORT_SYMBOL_GPL(acpi_get_sub);
acpi_status acpi_evaluate_reference(acpi_handle handle, acpi_string pathname, diff --git a/include/linux/acpi.h b/include/linux/acpi.h index 4f82a5bc6d98..9bf18adf5920 100644 --- a/include/linux/acpi.h +++ b/include/linux/acpi.h @@ -21,6 +21,8 @@ #endif #include <acpi/acpi.h>
+#define ACPI_MAX_SUB_BUF_SIZE 9
#ifdef CONFIG_ACPI
#include <linux/list.h> @@ -762,6 +764,7 @@ static inline u64 acpi_arch_get_root_pointer(void) #endif
int acpi_get_local_address(acpi_handle handle, u32 *addr); +int acpi_get_sub(acpi_handle handle, char *sub, size_t size);
#else /* !CONFIG_ACPI */
@@ -1023,6 +1026,11 @@ static inline int acpi_get_local_address(acpi_handle handle, u32 *addr) return -ENODEV; }
+static int acpi_get_sub(acpi_handle handle, char *sub, size_t size) +{
return -ENODEV;
+}
static inline int acpi_register_wakeup_handler(int wake_irq, bool (*wakeup)(void *context), void *context) { --