24 May
2019
24 May
'19
7:55 a.m.
On Thu, 23 May 2019 22:29:17 +0200, Gustavo A. R. Silva wrote:
Make use of the struct_size() helper instead of an open-coded version in order to avoid any potential type mistakes, in particular in the context in which this code is being used.
So, replace the following form:
sizeof(struct rate_priv) + src_format->channels * sizeof(struct rate_channel)
with:
struct_size(data, channels, src_format->channels)
This code was detected with the help of Coccinelle.
Signed-off-by: Gustavo A. R. Silva gustavo@embeddedor.com
Applied now, thanks.
Takashi