11 Oct
2017
11 Oct
'17
10:47 a.m.
Hi Mark
+void snd_soc_card_disconnect_sync(struct device *dev) +{
- struct snd_soc_component *component = snd_soc_lookup_component(dev, NULL);
- if (!component || !component->card)
return;
- snd_card_disconnect_sync(component->card->snd_card);
Is this the right name for ASoC or should it just be snd_soc_disconnect_sync()? It'll work for any device that's in a card.
Ahh, indeed. snd_soc_disconnect_sync() is better naming. I will fix name in v2 (Based on Takashi's branch)
Best regards --- Kuninori Morimoto