On Tue, Dec 12, 2023 at 11:47:36AM +0000, Srinivas Kandagatla wrote:
+int qcom_snd_tdm_hw_params(struct snd_pcm_substream *substream,
struct snd_pcm_hw_params *params)
+{
TBH, this should not be part of sdw.c file, its intended for more of soundwire specific helpers, pl consider moving this to common.c for now. Because, Not all old qcom platforms have soundwire controllers.
Acked.
ret = snd_soc_dai_set_tdm_slot(cpu_dai, 0, 0x3, 8, slot_width);
slot mask is always set to 2 channels in this case, should you not check the number of channels to determine the correct one?
These magic number 0, 0x3, 8 seems to make the code unreadable, can you do something like this: snd_soc_dai_set_tdm_slot(cpu_dai, tx_mask, rx_mask, ARRAY_SIZE(tdm_slot_offset), slot_width);
Acked.
}
- }
Finally ./sound/soc/qcom/sdm845.c does have exactly same code, can you consider removing this and make use of this new helper in that file too.
Acked.
Thanks for your reveiw very much, I will do it in patch v3.