On Tue, Feb 16, 2016 at 08:04:23PM +0530, Vaibhav Agarwal wrote:
As I said with regard to your changlogs please leave blank lines between paragraphs, it makes things much easier to read.
On 15 February 2016 at 22:32, Mark Brown broonie@kernel.org wrote:
On Mon, Feb 15, 2016 at 05:49:31PM +0530, Vaibhav Agarwal wrote:
+int snd_soc_add_dailink(struct snd_soc_card *card,
struct snd_soc_dai_link *dai_link);
+void snd_soc_remove_dailink(struct snd_soc_card *card, const char *link_name);
Everywhere else we write dai_link.
Another API snd_soc_add_dai_link() already exists (added by Mengdong). How about renaming it to snd_soc_create_dai_link() ?
No. Think about what you are saying here. You're having problems because you're trying to create a new function where the obvious names collide with existing functions. This suggests that hacking around with the naming isn't going to lead to a clear interface or implementation, users will be confused about what to do and we will most likely have code duplication in the implementation. Instead this should be addressed through looking at the structure of the code.