8 Jan
2012
8 Jan
'12
9:23 p.m.
On Sat, Jan 07, 2012 at 05:53:26PM -0800, Patrick Lai wrote:
ASoC currently has macro for double 8-bit signed TLV. Enhance info,get,put callback functions of SOC_DOUBLE_S8_TLV for single single 8-bit signed TLV.
Actually now I look at this I'm not sure that the existing macro isn't just misnamed:
| #define SOC_DOUBLE_S8_TLV(xname, xreg, xmin, xmax, tlv_array) \
Since no shifts are specified the signature is just the same as your SOC_SINGLE_S8_TLV:
+#define SOC_SINGLE_S8_TLV(xname, xreg, xmin, xmax, tlv_array) \
so it looks like what really ought to happen here is that the existing macro gets renamed to the new macro and a new macro gets defined for double values if one is needed.