During the initial i.MX patch reviews on GitHub, we realized a lot of the i.MX mailbox/window code was common with the Intel loader code except for a couple of offsets. Most of the credit goes to Daniel Baluta for working on this series which adds a better abstraction and reduces code duplication. Comments from Keyon and Ranjani helped remove unnecessary parts kept for historical reasons and improve the code overall.
Daniel Baluta (6): ASoC: SOF: Remove call to snd_sof_dsp_mailbox_init ASoC: SOF: Introduce snd_sof_dsp_get_mailbox_offset ASoC: SOF: Introduce snd_sof_dsp_get_window_offset ASoC: SOF: Intel: byt: Refactor fw ready / mem windows creation ASoC: SOF: Intel: bdw: Use generic function for fw ready / mem windows creation ASoC: SOF: Intel: hda: Use generic function for fw ready / mem windows creation
sound/soc/sof/intel/apl.c | 4 +- sound/soc/sof/intel/bdw.c | 161 +++----------------------------- sound/soc/sof/intel/byt.c | 169 ++++------------------------------ sound/soc/sof/intel/cnl.c | 4 +- sound/soc/sof/intel/hda-ipc.c | 150 +----------------------------- sound/soc/sof/intel/hda.h | 4 +- sound/soc/sof/loader.c | 168 +++++++++++++++++++++++++++++++++ sound/soc/sof/ops.h | 18 ++++ sound/soc/sof/sof-priv.h | 6 ++ 9 files changed, 237 insertions(+), 447 deletions(-)